Админка в OpenCart не открывается

и выдаётся ошибка HTTP ERROR 500!

У меня есть свой интернет магазин и недавно я обнаружил, что сломалась админка. По сути, я ничего не делал в конфигах и поэтому был крайне удивлён данным обстоятельством. Немного потанцевав с бубном, полез на форумы. Огромное количество информации про vqmod и очистку кэша, про изменение файла config.php, после добавления SSL сертификата. Я проверил все самые популярные рекомендации, но админ-панель так и не хотела появляться.

Удивительно, но всё оказалось проще некуда! В моём случае обнаружилось несоответствие версий PHP на хостинге и на сайте. Я не утверждаю, что это поможет вам, так как причин ошибок в админке OpenCart достаточно много. Я лишь рассказываю о том, что мне помогло решить проблему.

Как оказалось, сайт моего интернет-магазина не поддерживает версию PHP 7.1 и далее. Но, каким-то образом, версия скриптового языка на хостинге переключилась. Возможно, это происки США, но не точно. Таким образом, чтобы достичь желаемой цели, необходимо зайти на сайт своего хостера (в моём случае это TimeWeb), перейти в раздел «Сайты», тыкнуть «Настройки*, поменять версию PHP и сохранить изменения. Всё элементарно!

Я выбрал версию PHP 5.6, и у меня всё заработало! Теперь по адресу мойсайт.ru/admin/ открывается хорошо знакомая форма авторизации OpenCart.

Решение проблемы подсмотрел здесь.

Поделиться
Отправить
Запинить
 242   5 мес   Интернет
Популярное